BladeAssure in MX1/M3 Experiencing issues with Ply Label Recognition

Incident
June 04 2026, 10:35am

BladeAssure in MX1/M3 Experiencing issues with Ply Label Recognition

Status: closed
Start: June 04 2026, 9:13am
End: June 04 2026, 10:35am
Duration: 1 hour 22 minutes
Affected Components:
BladeAssure - Production
Update

June 04 2026, 9:13am

June 04 2026, 9:13am

We are experiencing issues in MX1 and MX3 with BladeAssure with Label Recognition. We have the support team fully engaged and are working to resolve. 

Resolved

June 04 2026, 10:35am

June 04 2026, 10:35am

A fix was applied to the application. Initial indicators are positive. We will continue to monitor.