BladeAssure is not Functioning

Incident
May 27 2026, 9:33am

BladeAssure is not Functioning

Status: closed
Start: May 27 2026, 7:01am
End: May 27 2026, 9:33am
Duration: 2 hours 32 minutes
Affected Components:
BladeAssure - Production
Update

May 27 2026, 7:01am

May 27 2026, 7:01am

BladeAssure is not functioning. We have engaged the support team and are working through to determine the issue. 

Update

May 27 2026, 7:30am

May 27 2026, 7:30am

The BladeAssure application is now available. We will continue to monitor and determine root cause. I apologize for the inconvenience. 

Resolved

May 27 2026, 9:33am

May 27 2026, 9:33am

Issued has been resolved.