Reverse Integration Paycode data not getting loaded into LE2.0

Incident
November 17 2025, 9:36pm

Reverse Integration Paycode data not getting loaded into LE2.0

Status: closed
Start: November 13 2025, 8:13pm
End: November 17 2025, 9:27pm
Duration: 4 days 1 hour 14 minutes
Affected Components:
Global Applications Leading Edge (LE) 2.0
Update

November 13 2025, 8:13pm

November 13 2025, 8:13pm

Hi All

   Reverse integration paycode data is not getting loaded into LE2.0 subsequently affecting payroll process.

   Initial investigation shows files are successfully delivered from ADP to LE2.0 and mapping exists correctly in the application.

   Application team is further debugging as to why files aren't getting processed.

   We'll keep you posted with updates.


Thanks & Regards,

LE2.0 - IT Support

Update

November 13 2025, 10:34pm

November 13 2025, 10:34pm

Hi Team

     Further investigation reveals error in logs while processing file from ADP into LE2.0.

     Application team is further checking at code level as to what is causing this error.

    We'll keep you posted with updates.

Thanks & Regards,

LE2.0 - IT Support

Update

November 14 2025, 5:25am

November 14 2025, 5:25am

Hi Team

    Files received from ADP to LE2.0 are getting processed after 13th November 2025 18 MST.

    Application team still investigating as to why files are getting errored for certain period yesterday - also entries mentioned by payroll team for investigation are still not appearing in LE2.0.

   We'll keep you posted further with updates.


Thanks & Regards,

LE2.0 - IT Support

Update

November 14 2025, 9:26am

November 14 2025, 9:26am

Hi Team

   Payroll team has informed that time records are getting loaded successfully - but issues are with PTO and downtime record processing.

   Currently 148 records are being affected for last week which needs to be included for current payroll processing.

  Application team working on:

1. Analyzing what is causing this issue for PTO and downtime record.

2. Also checking possibility of backend update for affected records to see if this can fix the issue for current payroll.

We'll keep you posted with updates.


Thanks & Regards,

LE2.0 - IT Support

Resolved

November 17 2025, 9:27pm

November 17 2025, 9:27pm

Hi All

It seems there was data issues in files which got errored out - once application team corrected the same, all errored files started to get processed.

RCCA will be tracked separately to ensure same error won't happen in future.

Issue stands as resolved and no more further updates would be rolled out.

Thanks for your co-operation and patience.


Thanks & Regards

LE2.0 - IT Support

Root Cause

November 17 2025, 9:36pm

November 17 2025, 9:36pm

Hi All

Root Cause: Comment field entered in LE2.0 was processed and sent out to ADP -as part of reverse integration while ADP sent the data back to LE2.0, it wasn't able to process and the files got errored out. Once those values were temporarily corrected, processing happened correctly.

Permanent Fix: LE2.0 system need to validate comment section column to ensure values are acceptable and same can be processed during reverse integration process while files coming from ADP. Development team will work on the same for proper closure.

Thanks & Regards

LE2.0 - IT Support