Reverse Integration Paycode Data not loading into LE2.0

Incident
October 31 2025, 1:27pm

Reverse Integration Paycode Data not loading into LE2.0

Status: closed
Start: October 29 2025, 7:17pm
End: October 31 2025, 1:27pm
Duration: 1 day 18 hours 10 minutes
Affected Components:
Global Applications Leading Edge (LE) 2.0
Update

October 29 2025, 7:17pm

October 29 2025, 7:17pm

In LE2.0 system, it appears that reverse integration paycode data not loading from ADP.

IT teams are actively investigating on the same with priority.


Thanks

LE2.0 - IT Support

Update

October 29 2025, 8:37pm

October 29 2025, 8:37pm

Issue reported by users are being analyzed in code level now.

We'll keep posted with updates.

Thanks

LE2.0 - IT Support

Update

October 29 2025, 9:32pm

October 29 2025, 9:32pm

Initial Investigation shows file sent from ADP for reverse integration are not being processed by LE2.0 system - further analysis is being done on the same.

Update

October 29 2025, 11:32pm

October 29 2025, 11:32pm

Code analysis is still in progress - not identified the issue yet.

We'll keep posted with updates.

Thanks

LE2.0 - IT Support

Update

October 30 2025, 6:20am

October 30 2025, 6:20am

Still issue is not yet identified - Alan's expertise is being involved currently for further investigation. Also various code versions are being checked for finding the exact flow for the same.

We'll keep posted with further updates.

Thanks

LE2.0 - IT Support

Update

October 31 2025, 7:24am

October 31 2025, 7:24am

Further investigations are happening in code level - suspecting to be a mapping issue between the ADP time entries files and the configuration in LE2.0.

We'll keep posted with further updates.

Thanks

LE2.0 - IT Support

Update

October 31 2025, 10:09am

October 31 2025, 10:09am

After correcting the mapping entries in database, we can see ADP files are getting processed via reverse integration process.

Further checks are going on with payroll team to have all scenarios of files being pushed and ensure it gets processed.

We'll keep posted with further updates.

Thanks

LE2.0 - IT Support

Update

October 31 2025, 11:11am

October 31 2025, 11:11am

Issue to generate the ADP Files have been resolved and the files have been sent over - ETA for job schedule to pickup and process files present currently in queue  is 50 mins.

Completeness of processing will be verified at that time and will be decided if issue has been completely fixed.

We'll keep posted with further updates.

Thanks

LE2.0 - IT Support


Update

October 31 2025, 1:10pm

October 31 2025, 1:10pm

All files have been processed successfully without any errors - final step of doing hours validation between ADP and LE2.0 is in progress to see if all things are in sync.

We'll keep posted with further updates.

Thanks

LE2.0 - IT Support


Resolved

October 31 2025, 1:27pm

October 31 2025, 1:27pm

Hours validation between ADP and LE2.0 was verified from the report generated and payroll team confirmed looks good and issue has been resolved.

Root cause and fix proposals will be followed separately as part of RCCA processing.

Issue stands as resolved and no more further updates would be rolled out.

Thanks for your patience and understanding.

Thanks

LE2.0 - IT Support