LE 2.0 - Unable to issue invoices to LE for intercompany invoices

Incident
October 01 2025, 1:26pm

LE 2.0 - Unable to issue invoices to LE for intercompany invoices

Status: closed
Start: September 30 2025, 10:30pm
End: October 01 2025, 1:26pm
Duration: 14 hours 56 minutes
Affected Components:
Global Applications Leading Edge (LE) 2.0
Update

September 30 2025, 10:30pm

September 30 2025, 10:30pm

LE 2.0 - Unable to issue invoices to LE for intercompany invoices

Error pops up when new invoice is created, amount is issued but invoice is not visible and is not assigned to tech weeks.

IT team is in bridge call to investigate further.

Thanks,

LE2.0 IT Support

Update

September 30 2025, 10:47pm

September 30 2025, 10:47pm

User has been involved in call and has been explained about the error/issue faced in report.

LE2.0 IT team is further investigating on issue reported.

Thanks

LE2.0 - IT Support

Update

September 30 2025, 11:01pm

September 30 2025, 11:01pm

Issue has been reproduced in QA - now IT team checking with business if same error happens in production.

IT team checking of any recent release in production is causing this behavior.

Thanks

LE2.0 - IT Support

Update

September 30 2025, 11:55pm

September 30 2025, 11:55pm

User again tried the scenario in QA and it worked fine - able to assign invoices for all scenarios.

Issue exists only in PROD - IT team suspecting of any code mismatch between QA and Prod which they are checking currently.

Once confirmed, it will be discussed in morning in daily call and fix will be moved further into production.

Thanks

LE2.0 - IT Support

Update

October 01 2025, 5:52am

October 01 2025, 5:52am

Latest Update:

Prod backup is being migrated to prod - since more data, took more time to complete. IT team working to resolve the QA DB issues to get it operated.

Code comparison between QA and Prod in progress - UI is completed, Middleware is in progress.

Once QA is up, testing will be initiated with prod copy and see if same issue persists and investigate on the same further,

Thanks

LE2.0 - IT Support

Update

October 01 2025, 6:09am

October 01 2025, 6:09am

Latest Update:

Prod backup is being migrated to QA - since more data, took more time to complete. IT team working to resolve the QA DB issues to get it operated.

Code comparison between QA and Prod in progress - UI is completed, Middleware is in progress.

Once QA is up, testing will be initiated with prod copy and see if same issue persists and investigate on the same further,

Thanks

LE2.0 - IT Support

Update

October 01 2025, 7:26am

October 01 2025, 7:26am

Latest Update:

As testing in QA needs more time for dev and functional team, it has been decided to rollback the production code to previous working version.

We'll get back once rollback is fully completed in production (ETA ~ 1 hr).

Thanks

LE2.0 - IT Support

Update

October 01 2025, 9:35am

October 01 2025, 9:35am

Latest Update:

Production code has been rolled back to last successful version - user has tested and still facing issues in invoicing.

IT team is checking further on the same.

Thanks

LE2.0 - IT Support

Resolved

October 01 2025, 1:26pm

October 01 2025, 1:26pm

IT team has identified missing code which was causing issue for project details to get displayed (as of now single project detail was affected) - hence the code was properly synced in production after successful testing in QA and confirmed by user. Currently user is able to invoice the affected project without any issues in QA environment.

Syncing of code in production from QA will approximately take around 2 hrs from now after which missing project invoices can be fed upon.

Outstanding Issues which are no longer blocker:

  • Work week data was wrongly assigned for the migrated invoice data - data fix will be applied to get this corrected.
  • Edit screen doesn't show invoice lines, but still finance team able to assign the work week to the invoices - analysis and fix in progress.

Issue stands as resolved and no more updates will be rolled out. 

Thanks for your cooperation and patience.

Thanks & Regards

LE2.0 - IT Support