QMS App issue - unable to visualise evidence

Incident
September 22 2025, 12:58pm

QMS App issue - unable to visualise evidence

Status: closed
Start: September 22 2025, 5:22am
End: September 22 2025, 7:25am
Duration: 2 hours 3 minutes
Affected Components:
Global Applications QMS - Quality Management System
Update

September 22 2025, 5:22am

September 22 2025, 5:22am

QMS App issue reported - users are unable to visualize evidence in Production.

Photo download also not available in QMS Web.

TPI IT teams are checking with priority.

Update

September 22 2025, 5:41am

September 22 2025, 5:41am

All sites are reporting same issues and not able to progress.

TPI IT checked in UAT/non-prod and could see images are able to be viewed and visualize defects/repairs.

Further analysis being done to see if any changes in PROD.

Update

September 22 2025, 6:10am

September 22 2025, 6:10am

Current investigation shows there is a permission issue within AWS to access the images and publish the same.

IT Teams are further working to fix the same at the earliest.

Resolved

September 22 2025, 7:25am

September 22 2025, 7:25am

IT team identified the issue and fixed the issue - users also confirmed all working fine now.

RCA: One of the keys of the root users in AWS got expired over the weekend, this key is used to provide access to image folder in another account in AWS. Since keys got expired, access lost and functionality of fetching and saving images got broken. IT team redefined new keys and restarted the application and started to work thereupon. 

Issue is marked as closed and no more further updates will be rolled out.

Root Cause

September 22 2025, 12:58pm

September 22 2025, 12:58pm

One of the keys of the root users in AWS got expired over the weekend, this key is used to provide access to image folder in another account in AWS. Since keys got expired, access lost and functionality of fetching and saving images got broken. IT team redefined new keys and restarted the application and started to work thereupon. 

Still the access to S3 wasn't resolved and uploading of images didn't work properly. Upon checking further, service account used by service wasn't having proper permissions to retrieve and load the images, hence it was failing. Once required permission policy was enabled, uploading and saving of defects and images worked properly and got loaded into application successfully.

Application team working to implement alert to get notified about expiry of key setup and ensure to get renewed to avoid above issues in future.