Oracle lot number creation issue

Incident
September 02 2025, 11:48pm

Oracle lot number creation issue

Status: closed
Start: September 02 2025, 2:33am
End: September 02 2025, 9:52am
Duration: 7 hours 19 minutes
Affected Components:
Global Applications Oracle SCM
Update

September 02 2025, 2:33am

September 02 2025, 2:33am

We are having issue in GRN lot no generation  creatin issue and  we couldn't able to issue the new v120 preform kit as per yesterday &  today picklist blade no: 334, 335 & 336.

Currently Sev-1 raised with Oracle vendor and TPI IT working along with vendor. Also TPI IT identified that not all PO's are facing issues but only certain scenarios which is being used for reproducing and investigate the issue in non-prod

As workaround, Warehouse has requested existing kit to be used. Once IT issue is resolved, then as per BAU, workflows will be assigned accordingly.

We'll keep posted with updates further on the same.

Update

September 02 2025, 6:48am

September 02 2025, 6:48am

Currently User, TPI IT and Oracle vendor are in OWC call - error has been reproduced and further investigations going on.

TPI DBA team helping to check locks identified for user session and currently being investigated.

Update

September 02 2025, 7:21am

September 02 2025, 7:21am

On further investigation, it was identified scheduled program is overlapping with user session while creating lot numbers and causing row locks.

TPI IT is further checking on this and working to fix the same at the earliest.

Update

September 02 2025, 8:45am

September 02 2025, 8:45am

TPI IT has narrowed down the conflict/scheduling program causing row lock and currently disabled and killed existing session.

User is trying to create lot numbers in Prod and will update if its working fine.

We'll keep posted with updates.

Update

September 02 2025, 9:18am

September 02 2025, 9:18am

User is able to successfully create lot after TPI IT ensured problematic/long-running query job is kept on-hold.

TPI IT further discussing of how to enable without causing issues to lot creation process for users.

We'll keep you posted with updates.

Resolved

September 02 2025, 9:52am

September 02 2025, 9:52am

Lot Receipt creation is happening as BAU after problematic scheduled job is placed ON-HOLD.

TPI IT is investigating of possible fixes to not clash both the processes.

As of now, issue stands as resolved and no more further updates will be rolled out.

Please reach out to Oracle SCM Support Staff members for any further queries on this.

Thanks for your support and patience in getting it fixed!!

Root Cause

September 02 2025, 11:48pm

September 02 2025, 11:48pm

Permanent fix has been deployed by both TPI IT and Redwood Vendor - currently lot creation process and WMS scheduled program are running in parallel and not causing any issues or locks in DB level.

No more issues observed further on this process and is completely resolved.

Thanks for your patience and support!!